Pour rentrer dans le mode de configuration, taper








télécharger 129.55 Kb.
titrePour rentrer dans le mode de configuration, taper
page1/4
date de publication11.04.2017
taille129.55 Kb.
typeDocumentos
p.21-bal.com > documents > Documentos
  1   2   3   4
COMMANDES DE BASE ROUTEUR CISCO
Commandes de base :

erase startup-config : efface toute la configuration du routeur

reload : recharge la configuration enregistrer

write memory : écrit la configuration en cours dans la mémoire

Si l'on vient d'effacer la configuration,

Une configuration par défaut s'enregistre

? : donne les commandes disponible ou la suite des

commandes que l'on peut taper après

la commande en cours.
Pour rentrer dans le mode de configuration, taper :

enable

configure terminal : indique que l'on configure a partir d'un terminal
Configuration d'une interface Serial :

- configure terminal

- interface Serial 0/0 ou interface Serial 0/1

- ip address 128.10.0.1 255.255.0.0 (ip address ip_de_l'interface mask)

- clock rate 9600 (vitesse d'horloge)

- encapsulation hdlc (type d’encapsulation)

- no shutdown (pour activer l'interface)

On tape sur Ctrl Z pour revenir au menu racine

write memory pour enregistrer les modifications

show configuration pour visualiser la configuration

ou show interface Serial 0/0

On peut configurer plusieurs interfaces réseaux, elles seront actives en simultanée. Pour définir

une interface principale et une interface de secours, on définis une interface comme interface

backup

Lors de la configuration de l'interface, on tape

- configure terminal

- interface Ethernet 0/0 ou interface FastEthernet 0/1

On définie l’interface comme backup

Auquel on applique un délai. (2 paramètre de temps a donner)

Cette interface ne sera utilisé qu’en cas de coupure de l’autre interface et cela après un délais que

nous avons configurer.
Configuration d'une interface Ethernet :

- configure terminal

- interface Ethernet 0/0 ou interface FastEthernet 0/1

- ip address 192.168.0.10 255.255.0.0 (ip address ip_de_l'interface mask)

- no shutdown (pour activer l'interface)

On tape sur Ctrl Z pour revenir au menu racine

write memory pour enregistrer les modifications

show configuration pour visualiser la configuration

ou show interface Ethernet 0/0

Configuration du Routage :

On tape

ip route ip_reseau_a_atteindre mask ip_point_entré_reseau_a_atteindre

Exemple ip route 192.168.1.0 255.255.255.0 128.10.0.2

write memory

Pour quitter l'interface d'administration, on tape exit

1 Architecture :

    1. 1-1          Architecture interne

Tous les routeurs CISCO ont une architecture interne suivant le schéma ci-dessous :

 

image001

Avec NVRAm = Mémoire Ram non Volatile. La carte mère est en général intégrée au chassis. Par contre les interfaces sont des cartes additionnelles. Il existe des interfaces Ethernet, Token-Ring, série V35-V24, RNIS (ISDN), ATM, etc…

La CPU est un microprocesseur Motorolla de la famille 68000 avec un BIOS spécial nommé « I.O.S. » pour Internetwork Operating System.

 

La mémoire ram principale contient le logiciel IOS + la table de routage dynamique + un buffer pour les files d’attentes E/S. La mémoire flash contient une sauvegarde de l’IOS. La mémoire NVRAM contient la configuration du routeur + la configuration de l’IOS.

 

La mémoire ROM, quand à elle, contient un boot de démarrage et est utilisée pour des opération de maintenance difficiles.

    1. 1-2          Catégories de routeurs

 

  1. a)                 les Routeurs modulaires tels que les séries 7000 ; construits autour d’un chassis.

  2. b)                Les routeurs fixes tels que les séries 2500 ou 1000.

  3. c)                Les serveurs d’accès tels que les séries 750 ou 200.




    1. 1-3          L’ I.O.S.

L’IOS de CISCO a été conditionné en blocs de logiciels.

Donc, le routage IP supporte tous les protocoles de routage sous IP, les pontages transparents et de conversion, les lignes W.A.N. (X25, Numéris, Frame-relay, L.L.) ; ainsi que le routage Novell,.

 Pour pouvoir programmer le routeur, il faut utiliser plusieurs modes de configuration, pour lesquels certains sont protégés par mots de passe :

 

MODES

FONCTIONS

Router>

Mode Exec, (commandes éxécutables), accessible avec le « Unprivileged level » par un login qui nécessite un pasword (cmaker).

Router#

Mode Exec, avec Priviléges, pasword = cisco, qui permet de régler les paramètres de l’IOS.

>

Mode « Run Monitor » qui permet de reloader une configuration de boot.

Router(config)#

Mode de configuration globale, disponible en mode privilègié. Permet la configuration du terminal, des interfaces, des protocoles, etc…

 

  1. 2        Rappels TCP/IP :

    1. 2-1          Adresse de boucle

En règle générale, il existe une adresse réservée pour le test interne d’une interface. C’est la LOOPBACK address. L’auto-test est réalisé en éffectuant un test d’écho (ping) sur l’adresse 127.0.0.1

L’autotest n’a pas besoin du réseau extérieur, comme le montre le schéma ci-dessous : 

    1. 2-2          Règles d’adressage IP

Dans toute classe IP, les bits d’un Host-ID à 0 servent à identifier le réseau ; exemple 192.168.20.0. De même, les bits d’un Host-ID à 1 servent à identifier l’adresse de Diffusion (Broadcast) ; exemple 192.168.20.255.

Pour faire une affectation d’adresse IP sur les routeurs CISCO, il faut taper la commande suivante :

configure terminal

interface ethernet 0

ip address 192.168.230.12 255.255.255.0

 

CISCO autorise une adresse IP secondaire sur la même interface. Ceci est utile lors de la modification du plan d’adressage de votre réseau, pendant une phase de migration :

configure terminal

interface ethernet 0

ip address 192.168.230.12 255.255.255.0

ip address 144.168.10.221 255.255.255.0 secondary

 

    1. 2-3          Commandes ARP CISCO

Les informations de cache ARP sont effacées après une période de non-utilisation. Pour CISCO, la valeur par défaut est de 4h00. Par comparaison, Windows-NT elle est de 2 minutes ! ! !

 

Pour visualiser le contenu du cache ARP sur votre station Windows-NT

 

c:\arp –a

Interface : 144.19.74.60

Internet Address Physical Address Type

144.19.74.61 00-00-c0-11-94-5a dynamic

144.19.74.62 00-00-c0-02-94-5a dynamic

144.19.74.63 00-00-0c-42-20-15 dynamic

c:\

 

Pour visualiser le contenu du cache arp sur un routeur CISCO

 

Cisco>show ip arp

Protocol Address Age(min) Hardware-Addr Type Interface

Internet 144.19.74.60 0 0000-c030-3f97 arpa Ethernet 0

Internet 144.19.74.61 4 0000-c011-3fb7 arpa Ethernet 0

Internet 144.19.74.62 77 0000-c002-4f95 arpa Ethernet 0

Internet 144.19.74.63 - 0000-c038-2f85 arpa Ethernet 0

 

Pour définir la méthode d’encapsulation des paquets arp :

 

arp {arpa | probe | snap }

 

avec arpa pour l’ethernet II, probe pour HP et snap pour 802.3-SNAP.

 

Pour ajouter une entrée statique dans le cache arp :

 

arp 144.19.24.02 0800.0c00.1234.1234 arpa

 

Pour effacer le cache arp CISCO :

 

monrouteur# clear arp-cache

 

    1. 2-4          Table de Routage

Les routeurs ont des tables de routage, pour lesquelles on trouve :

  • -         un réseau de destination et un masque,

  • -         l’adresse du prochain saut,

  • -         une métrique de saut.

 

Exemple :

204.92.77.0 204.92.76.0 192.168.222.0

image003

Ce qui donne la table de routage pour R1 :

 

Réseau

Masque

Prochain Saut

Métrique

204.92.77.0

255.255.255.0

204.92.77.01

0

204.92.76.0

255.255.255.0

204.92.77.02

0

192.168.222.0

255.255.255.0

204.92.76.01

1

 

 

 

 

 

Cette table est consultable avec l’instruction :

 

Show ip route

 

    1. 2-5          Création d’une entrée statique

Dans le schéma précédent, nous allons entrer pour chacun des routeurs, les routes statiques des extrémités les plus éloignées :

 

R1 ip route 192.168.222.0 255.255.255.0 204.92.76.01

 

R2 ip route 204.92.77.0 255.255.255.0 204.92.76.02

 

  1. 3        Protocoles de routage :

Les principaux protocoles de routages utilisés par CISCO sont RIP et IGRP.

    1. 3-1          Activation de R.I.P.

 

interface ethernet 0

ip address 204.92.76.1 255.255.255.0

interface token-ring 3

ip address 193.222.178.1 255.255.255.0

router rip

network 204.92.76.0

network 193.222.178.0

 

    1. 3-2          Activation de I.G.R.P.

 

interface ethernet 0

ip address 204.92.76.1 255.255.255.0

interface token-ring 3

ip address 193.222.178.1 255.255.255.0

router igrp 1

network 204.92.76.0

network 193.222.178.0

 

  1. 4        Routage IPX :

    1. 4-1          Architecture NOVELL

Novell de NetWare, présente une architecture Client/Serveur EXCLUSIVEMENT !

De ce fait, les communications d’égal à égal ne sont pas possibles. Toutes les transactions sont éffectuées au travers d’un serveur Novell.

 

Au travers de ce serveur, les clients ont des accès limités aux répertoires partagés par le serveur, aux files d’impression et aux services de courrier électronique.

 

La structure des protocoles utilisés par NetWare est la suivante :

 

 

 

 

 

Programmes Applicatifs

 

 

 

 

Transport

Novell RIP

Error

Echo

Netware Core protocol

N.C.P.

S.P.X.

Service Adversiting Protocol

S.A.P

Réseau

Internetwork Packet Exchange (IPX)

Liaison

Ethernet 802.3

Physique

10 base T

 

    1. 4-2          Adressage IPX

Les adresses IPX contiennent à la fois l’identificateur NETID et HOSTID. Tous les équipements sur le même segment de réseau ont le même NETID. Chaque équipement du réseau possède un HOSTID unique.

 

L’adresse IPX est donc constitué de l’adresse IPX du réseau + l’adresse IPX de la machine. Et c’est tout.

    1. 4-3          Activation du routage I.P.X.

Configure terminal

Ipx routing

Interface ethernet 0

Ipx network 0123456

Interface ethernet 1

Ipx network 456789

 

  1. 5        Interfaces Série :

    1. 5-1          Routage via des WANs

Un réseau local ne fournit qu’une connectivité dans une zone géographique limitée. Il est souvent nécessaire de raccordes des sites distants. Pour cela, une encapsulation par un protocole WAN est indispensable. Le schéma ci-dessous est un exemple :

 

TELNET

 

 

 

TELNET

TCP

 

 

 

TCP

IP

 

 

 

IP

802.3

HDLC

 

 

 

HDLC

802.5

10 base T

V35

 

 

 

V35

Token

 

Dans le schéma ci-dessus, chacun des routeurs utilise deux interfaces : une interface LAN et une interface HDLC/V35 qui sera connectée à un modem, puis à un opérateur tel que France télécom. (RNIS ou RTC ou Transpac…)

    1. 5-2          Activation des encapsulations

Configure terminal

Interface serial 0

Encapsulation ppp

Ip address

 

  1. 6        Pontage Transparent :

    1. 6-1          Relayage des protocoles non-routables

Tous les nœuds de réseaux se relayent les trames en se basant sur l’adresse de réseau IP ou IPX principalement.

 

Dans une procédure de routage, les adresses MAC sont retirées, puis les données sont transmises au niveau réseau.

 

Mais que se passe t-il donc si le protocole n’a pas de couche réseau ?

 

La réponse est simple : les trames ne passent pas ! Il faut donc utiliser la technique du pontage, qui consiste à établir un relais basé sur l’identification de MAC adresse.

 

Ceci est indispensable pour les protocoles suivants :

 

DEC LAT :

Le système de Digital

NetBeui :

Microsoft NT ou IBM lan manager

NetBios :

Lantastic

SNA :

IBM

 

    1. 6-2          Configuration simple de pontage

Configure terminal

Bridge 1 protocol ieee

Interface ethernet 0

Bridge-group 1

Interface ethernet 1

Bridge-group 1

Exit

 

  1. 7        Mise à jour :

Eléments du routeur CISCO pouvant être mis à jour :

 

  • -         la rom de Boot

  • -         la mémoire flash

  • -         l’IOS

  • -         la mémoire principale

 

La plupart de ces mises à jour se font à partir du site web de CISCO. L’accès aux patchs et releases est soumis à un contrat de maintenance payant. Le coût est prohibitif pour une école.

 

Le cas le plus fréquent est la mise à jour de l’IOS ; ce qui nécessite la mise en place d’un serveur TFTP. (on en trouve d’excellent en shareware et pas cherware du tout)

  1   2   3   4

similaire:

Pour rentrer dans le mode de configuration, taper iconLéonie de la Palmeraie et sa fille Marie-Alix venaient de rentrer...

Pour rentrer dans le mode de configuration, taper icon1. Combien est-ce que la mode/les vêtements sont importants dans la vie pour toi ?

Pour rentrer dans le mode de configuration, taper iconAprès avoir rempli sa mission, notre jeune héros avait quitté Suna...

Pour rentrer dans le mode de configuration, taper icon1) Parmi les commandes suivantes, lesquelles peuvent être utilisées...

Pour rentrer dans le mode de configuration, taper iconRépondre à l’appel d’offre de la société de l’oid pour la configuration...
«traitement d’image, son et vidéo (4 postes à fournir)/ Postes métier «création numérique» (10 postes à fournir). 7

Pour rentrer dans le mode de configuration, taper iconSur mon mur : democratie mode d'emploi, en immersion dans la campagne presidentielle francaise

Pour rentrer dans le mode de configuration, taper iconConfiguration electronique

Pour rentrer dans le mode de configuration, taper iconBut Découvrir le mode de gélification de l’agar-agar dans une recette...

Pour rentrer dans le mode de configuration, taper iconCulture: la culture est un espace dans lequel coexiste des systèmes...

Pour rentrer dans le mode de configuration, taper iconExercice 1 : Le rôle du concentrateur et de la carte réseau
«décisions» prises par les différents matériels. IL est préférable d’utiliser ce mode dans un second temps et de montrer d’abord...








Tous droits réservés. Copyright © 2016
contacts
p.21-bal.com